При вводе команды freshclam выдает ошибки на libclam, а так же, что уровень защиты очень низкий.

При вводе clamscan -ri / ничего не сканирует.

Дело в том, что в стандартных репозитариях clam-update немного кривой.

Лечится добавлением в /etc/apt/sources.list:

deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

Затем

# apt-get update

# apt-get upgrade

После чего база обновится автоматически и можно приступать к сканированию.