Такая ошибка означает, что скрипт пытается запросить больше памяти, чем ему разрешено.

Решение: нужно увеличить размер memory_limit в php.ini

В Debian:

Если php используется как модуль апача:

/etc/php5/apache2/php.ini

Если php используется как CGI или FastCGI:

/etc/php5/cgi/php.ini

Если PHP используется как CLI:

/etc/php5/cli/php.ini

В CentOS:

/etc/php.ini